
Introducing Norton Registry Tracker

Norton Registry Tracker helps you keep track of changes made to critical files, folders, and
registry keys on your system. Norton Registry Tracker takes "snapshots" of tracked items 
when they change, showing you the changes that were made and allowing you to restore 
tracked items to their former state with the Quick Fix and Restore features.
Most applications change either the registry or an initialization (INI) file when you install 
them.    In some cases, you may not be happy with the changes. Building and maintaining 
an "audit trail" of system snapshots with Norton Registry Tracker can save hours of 
frustrating trial and error to restore your system to its original state. 
In addition to registry keys and text files, Norton Registry Tracker lets you track changes to
data files and folders on your system. Data files store information in binary (non-text) 
form; they frequently have a DAT file extension. While Norton Registry Tracker can't show 
you the exact changes made to these types of files, it does allow you to restore earlier 
versions, should the data become corrupted. Whenever a change is made to a tracked 
folder, Norton Registry Tracker takes a snapshot to show you what files were added or 
deleted.
You can configure Norton Registry Tracker to start automatically and run in the 
background whenever you start Windows. The camera icon in the notification area (right 
side) of the Windows taskbar tells you Norton Registry Tracker is running and continually 
monitoring changes to the items you have specified for tracking.
If you choose not to run Norton Registry Tracker continuously in the background, we 
recommend that you run it at the very least whenever you add, modify, or remove any 
hardware or software on your system. Norton Registry Tracker takes a new snapshot when
it starts, thus keeping a log of the tracked items on your system through the most critical 
periods of change.
To track registry changes, click here        to start Norton Registry Tracker.
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About tracked items

By default, Norton Registry Tracker tracks the following items on your computer:
The Windows folder (usually C:\WINDOWS)
The Windows System folder (usually C:\WINDOWS\SYSTEM)
The HKEY_LOCAL_MACHINE\SOFTWARE registry key and the subkeys it contains
WIN.INI
SYSTEM.INI
CONFIG.SYS
AUTOEXEC.BAT

You can specify additional items to track, and remove tracking from any of the default 
items if you wish. Choose Settings from the Options menu to specify items for tracking. 
From the Registry Keys tab you can specify whether Norton Registry Tracker should track a
key alone (Track Key) or the key together with all subkeys it contains (Track Subtree).
Whenever Norton Registry Tracker detects a change to one of the tracked items, it takes a
new snapshot. Thus, each new snapshot records the changes made since the previous 
snapshot was taken. Taken together, the Norton Registry Tracker snapshots provide a log 
of modifications made to tracked items. Norton Registry Tracker can use these snapshots 
to restore any tracked item to its state at the time of any snapshot.

Tracking items that change continually, like dynamic registry keys or the Windows 
swap file, triggers frequent snapshots. You should avoid tracking these types of items, or 
mark them as tracking exclusions. On the other hand, you may want to track a database or 
word processing file as you work on it, to have a record of changes you can undo if need be.
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Excluding items from tracking

In some cases, you may not want to track a particular item:
Windows automatically maintains a set of registry keys that record performance 

statistics for various system functions. These values are continually being updated, yet have
no effect on your system. Were you to track these registry keys, Norton Registry Tracker 
would take frequent, unnecessary snapshots.

The size of the Windows swap file changes dynamically with the needs of the system.
If you track the folder that contains this file, Norton Registry Tracker would take a new 
snapshot with every change in swap file size. For this reason, the Windows swap file is 
excluded from tracking automatically.

Some initialization (INI) files include sections whose contents are updated frequently 
by their associated application programs. Because this data is not critical to the functioning 
of your system, you may not want these sections tracked.
Normally you would simply choose not to track these types of registry keys and files. But if
you choose to track the registry key or folder that contains them, these items would be 
included in the tracking automatically. You can prevent this by explicitly excluding these 
types of items.
It's easy to exclude specific registry keys, files, folders, or INI file sections from tracking 
with Norton Registry Tracker. Right-click the item in the Snapshot Log that you want to 
exclude from future tracking, and choose Exclude.

You cannot exclude registry values from tracking; only the keys that contain them.
You can also remove exclusions easily from the Settings dialog box tabs. Check the Show 
Exclusions checkbox, select the excluded item you wish to include in future tracking, and 
click Remove to remove that exclusion. From the Registry Keys tab you can specify 
whether a key alone is to be excluded (Exclude Key) or the key together with any subkeys 
it contains (Exclude Subtree).
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Editing EXCLUDE.INI

Norton Registry Tracker uses its own INI file to keep track of two types of exclusions:
Files that are excluded from their containing folder's tracking
Specific INI file entries that are excluded from their parent INI file's tracking

These types of exclusions are specified in the file EXCLUDE.INI, which is stored in the 
REGTRK folder under Norton Utilities. Normally, this file is updated automatically 
whenever you add or remove these types of exclusions, but you may freely edit this file if 
you wish. Use your favorite text editor, such as Windows Notepad.
EXCLUDE.INI is broken down into sections, each of which represents a tracked folder or INI 
file. Entries under folder sections represent files; entries under INI file sections represent 
entries in those INI files. If an entry is set equal to one, the file or INI entry it represents is 
excluded from tracking. Norton Registry Tracker ignores changes to these files or INI 
entries.
If you delete entries in EXCLUDE.INI, Norton Registry Tracker tracks the corresponding files
or INI file entries again.

{button ,AL(`Excluding items from tracking;To exclude items from tracking;To remove 
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About Norton Registry Tracker snapshots

Whenever Norton Registry Tracker detects a change to a tracked item, it takes a new 
snapshot. Each snapshot captures the state of the tracked items on your system. There 
are three main types of events that trigger Norton Registry Tracker to take a snapshot:

Whenever Norton Registry Tracker starts, it takes a snapshot to serve as a baseline 
record of the initial state of tracked items. If this snapshot differs from the last snapshot 
stored for your system, or if it is the first time you have run Norton Registry Tracker, the 
snapshot is labeled an "Activation Snapshot".

Whenever Norton Registry Tracker detects a change to a tracked item it takes a new 
snapshot. This allows you to compare the snapshot with previous snapshots to see what 
changes were made. Having a series of snapshots also lets you restore your system to the 
state it was in prior to any changes recorded in the snapshots.

You can also "force" Norton Registry Tracker to take a snapshot (a "manual snapshot")
at any time. It is a good idea to take a manual snapshot prior to making major changes in 
your system, such as installing new hardware or software. Taking a manual snapshot allows 
you to name the snapshot anything you like.
To help you locate changes quickly, Norton Registry Tracker snapshots can display only 
those items that have changed since the previous snapshot.
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About the Snapshot Log

The Snapshot Log is where Norton Registry Tracker displays a list of snapshots it has 
taken.
Whenever Norton Registry Tracker starts, it takes a snapshot of your system. If this 
snapshot differs from the final snapshot from the last Norton Registry Tracker session, (or 
if this is the first time you have run Norton Registry Tracker) this snapshot is labeled an 
"Activation Snapshot," and functions as a baseline to record an initial state for tracked 
items.
If there is a previously stored snapshot, and Norton Registry Tracker detects no changes 
between it and the new snapshot, the new snapshot is not saved. In this case, Norton 
Registry Tracker updates the Last Checked time displayed at the top of the Snapshot Log.
Any time Norton Registry Tracker detects a change to a tracked item, it takes a new 
snapshot to record the changes. Automatic snapshots are tagged with the date and time 
of the snapshot, and the program that effected the change. You can also force Norton 
Registry Tracker to take a snapshot at any time, whether or not there have been changes 
made to tracked items. These "manual snapshots" are also tagged with the date and time.
By default, they are labeled "Manual Snapshot," but they can be labeled anything you like.
You can display the Snapshot Log sorted either "By File" (by tracked items) or "By 
Snapshot." The log is displayed in an expandable browser format similar to that used by 
the Windows Explorer. Items with plus signs to their left can be "expanded" by clicking on 
the plus sign to reveal more details. At the finest level of detail (items fully expanded), the
Snapshot Log shows changes made to the tracked items. Specific changes are not 
displayed for binary files.
By default, the Snapshot Log displays full details of the snapshot contents, and the 
changes that occurred between snapshots. Use the View menu to change the level of 
detail displayed.
You can reset the snapshot log by choosing Reset Snapshot Log from the Options menu. 
After the Snapshot Log is reset, Norton Registry Tracker automatically takes a new 
snapshot to record baseline conditions of tracked items.

Resetting the Snapshot Log erases any existing snapshots, then takes a new 
snapshot. After resetting the Snapshot Log you will not be able to restore tracked items to 
the state they were in prior to the reset. Reset the Snapshot Log only if you are certain you 
will not need to restore information from the currently existing snapshots.
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How changes to tracked items are displayed

Norton Registry Tracker lets you select which registry keys and INI file sections should be 
tracked. Whenever a change is made to a tracked item, the change is recorded in the 
Snapshot Log.
Changes to tracked items are indicated by the icons to the left of the items:

Indicates something that has been added.
Indicates something that has been removed.
Indicates a line in a text file that has been moved within a file.

The moved text is preceded by the line number from which the text was moved.
Indicates a line in a text file that has been moved within a file.

The moved text is preceded by the line number to which the text was moved.
For an on-screen reminder of these symbols, choose Legend from the View menu.

A line moved in a text file is generally shown in the Snapshot Log as a paired change with 
the first line indicating where the line was moved to, and below that a line indicating 
where the line was moved from. You'll also frequently see paired add/delete change lines. 
These indicate an existing value that has been changed, since a change involves 
essentially deleting the old value and adding the new value.
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Recovering previous versions of tracked items

The latest Norton Registry Tracker snapshot captures the current state of your tracked 
items. If you ever need to recover earlier versions of your tracked items, Norton Registry 
Tracker gives you two ways of doing so:

Quick Fix reinstates all tracked items from the snapshot immediately preceding the 
current snapshot. It returns these items to the state they were in just prior to the last 
snapshot. Choose Quick Fix from the file menu.

Restore reinstates selected tracked items from a specific snapshot. Just select a 
snapshot from the Snapshot Log, then choose Restore from the File menu. A dialog box lets 
you designate which of the tracked items from the snapshot should be restored. You can also
right-click a registry key in the snapshot log and choose Restore.

Norton Registry Tracker cannot reverse changes that have been made to tracked 
folders.
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To take a manual snapshot
1 Click here        to start Norton Registry Tracker.
2 Choose New Snapshot from the File menu.
3 Type in a name for the new snapshot, or use the default, "Manual Snapshot."

If none of the tracked files and folders have changed since the last snapshot, the 
latest snapshot in the snapshot log is simply renamed to the name you specified in the New 
Snapshot dialog box ("Manual Snapshot" is the default name).

{button ,AL(`Introducing Norton Registry Tracker;To specify items to be tracked',0,`',`')}    
Related Topics



To undo the most recent changes (Quick Fix)
1 Click here        to start Norton Registry Tracker.
2 Choose Quick Fix from the File menu. The Quick Fix dialog box lists the files and registry

keys whose changes will be reversed.
After Norton Registry Tracker reverses the changed items, it takes another snapshot and 
labels it "Snapshot After Restore." Because files and/or registry keys have been restored, 
the changes may not take effect until the system is restarted. Norton Registry Tracker 
gives you the option of restarting your system or continuing with your work.
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To restore files and registry keys
1 Click here        to start Norton Registry Tracker.
2 From the Snapshot Log, click the snapshot from which you want to restore files or keys.
3 Choose Restore from the File menu.
4 Click the files and keys in the list that you want to restore. Only the items selected will 

be changed.
5 Click OK.
Registry Tracker restores the selected items and takes a new snapshot labeled Snapshot 
After Restore.
Depending on the files and keys that are restored, some changes may not take effect until
the system is restarted. Norton Registry Tracker asks you if you want to restart or continue
working.
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To compare versions of tracked items
1 Click here        to start Norton Registry Tracker.
2 Click a tracked item in the Snapshot Log.
3 Choose Compare from the File menu.
Norton Registry Tracker runs Norton File Compare to compare versions of the item.
If the most recent version of the item is selected in the Snapshot Log, the item is 
compared to the version in the previous snapshot. If an older version of the item is 
selected in the Snapshot Log, Norton Registry Tracker gives you the option of comparing it
with the previous or current version.
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To exclude items from tracking
1 Click here        to start Norton Registry Tracker.
2 Right-click the item in the Snapshot Log that you want excluded from further tracking.
3 Click Exclude.

You can exclude registry keys, but not specific registry values, from tracking.
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To remove tracking exclusions
1 Click here        to start Norton Registry Tracker.
2 Choose Settings from the Options menu.
3 Click the Text Files, Folders, or Registry Keys tab, as appropriate.
4 Check the Show Exclusions check box (Text files and Folders tabs only).
5 If necessary, click the plus signs to show the exclusion you want to cancel.
6 Click the exclusion to select it.
7 Click Remove.
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To specify items to be tracked
1 Click here        to start Norton Registry Tracker.
2 Choose Settings from the Options menu.
3 Click the tab for the type of item you want to track. INI files are Text Files, binary files 

are Data Files.
4 Click Add.
5 Select the specific item you want Norton Registry Tracker to start monitoring.
6 Click Open.

Although Registry Tracker can track folders for changes, Registry Tracker cannot 
Quick Fix or Restore folders from snapshots.
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To remove items from tracking
1 Click here        to start Norton Registry Tracker.
2 Choose Settings from the Options menu.
3 Click the tab for the type of item you want to remove: .INI files are Text Files, binary 

files are Data Files.
4 Click Remove.
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To reset the Snapshot Log
1 Click here        to start Norton Registry Tracker.
2 Choose Reset Snapshot Log from the Options menu.
Resetting the Snapshot Log erases any existing snapshots, then takes a new snapshot. 
After resetting the Snapshot Log you will not be able to restore tracked items to the state 
they were in prior to the reset. Reset the Snapshot Log only if you are certain you will not 
need to restore information from the currently existing snapshots.

{button ,AL(`Introducing Norton Registry Tracker;About tracked items;To take a manual 
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To hide Norton Registry Tracker
1 Click here        to start Norton Registry Tracker.
2 Choose Hide from the File Menu.

To redisplay Norton Registry Tracker, click the camera icon in the notification area of 
the Windows taskbar (the area at the right side of the taskbar). The Norton Registry Tracker 
Snapshot Log will reappear.

{button ,AL(`Introducing Norton Registry Tracker;To open Norton Registry Tracker',0,`',`')} 
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To open Norton Registry Tracker

You can open any of the Norton Utilities programs from Norton Utilities Integrator. 
To open Norton Registry Tracker:
1 Double-click Norton Utilities Integrator on the Windows desktop.
2 Click Preventative Maintenance in the left pane.
3 Click Norton Registry Tracker in the right pane.

Or click here    
    to start Norton Registry Tracker now.
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To start Norton Registry Tracker at Windows startup
1 Click here        to start Norton Registry Tracker, if it is not already running.

2 Choose Settings from the Options menu.
3 Check Start Automatically With Windows.

To have Norton Registry Tracker run hidden, choose Hide from the File menu. 
Subsequently, Norton Registry Tracker will start automatically and run hidden whenever you 
start Windows. To redisplay Norton Registry Tracker, click the camera icon in the notification 
area of the Windows taskbar (the area at the right side of the taskbar).

{button ,AL(`Introducing Norton Registry Tracker;To specify items to be tracked;To hide 
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Enter a description for the new snapshot.



Clears the Norton Registry Tracker snapshot data files.
Resetting the Snapshot Log erases any existing snapshots, then takes a new 

snapshot. After resetting the Snapshot Log you will not be able to restore tracked items to 
the state they were in prior to the reset. Reset the Snapshot Log only if you are certain you 
will not need to restore information from the currently existing snapshots.



Cancels this operation without resetting Norton Registry Tracker.



Lists the tracked files and registry keys that changed in the last snapshot. These files will be 
returned to the state they were in prior to the last snapshot.



Lists the tracked files and registry keys that had changes recorded in the selected snapshot. 
The items you select from this list will be restored to the state they were in immediately 
following the selected snapshot.
Click items in the list to select (highlight) and deselect them. Only the selected items will be 
restored.



Compares the selected snapshot with the version previous to it.



Compares the selected snapshot with the current snapshot.



Loads Norton Registry Tracker automatically whenever Windows is started.



Automatically removes old snapshots after a specified number of days. To change the 
number of days between purges, use the up and down buttons on the box at the right, or 
type a new number.



Sets the maximum number of snapshots that Norton Registry Tracker stores. As new 
snapshots beyond this number are taken, the oldest snapshots are automatically deleted 
from your system. To change the number, use the up and down buttons on the box at the 
right, or type in a new number.



Shows only those items in the Snapshot Log that have changed between snapshots. If this 
box is unchecked, each snapshot lists all tracked items, regardless of whether there have 
been changes to the items.



Determines whether change details are shown in the Snapshot Log.



Determines whether the Snapshot Log legend is displayed. The legend is displayed at the 
bottom, in the status bar.
This option is only available when Show Details is checked.



Shows all currently tracked text files, for example, INI files.



Lets you specify a new text file to be tracked.



Removes the selected text file from the list of tracked files, and prevents the file from 
being tracked in the future.



Shows INI file entries that have been excluded from tracking.



Shows all currently tracked data (binary format) files.



Lets you specify a new data (binary format) file to be tracked.



Removes the selected data (binary format) file from the list of tracked files and prevents 
the file from being tracked in the future.



Shows all currently tracked folders.



Lets you specify a new folder to be tracked.



Removes the selected folder from the list of tracked folders and prevents the folder from 
being tracked in the future.



Shows files that have been excluded from tracking. Norton Registry Tracker ignores 
changes to these files when determining what folders have changed.



Shows the Windows registry hierarchy. Registry keys marked with a camera icon are being 
tracked; those marked with a camera-and-tree icon also have their subkeys tracked, and the 
tracked subkeys have checkmarks on their folder icons. Subkeys that have been excluded 
from tracking lack checkmarks on their folders.



Click to track the currently selected key.



Click to track the currently selected key and all subkeys it contains.



Click to exclude the currently selected key from tracking.



Click to exclude the currently selected key and its subkeys from tracking.



Click to clear selected key of checkmark. Subsequently, the key will be tracked or excluded 
only if its parent key is marked for subtree tracking or exclusion.



Displays only those branches of the registry that are currently being tracked.



Hides Norton Registry Tracker. Norton Registry Tracker continues to operate in the 
background, tracking changes to the specified files and folders.

A camera icon appears in the notification area (right side) of the Windows taskbar 
when Norton Registry Tracker is hidden.



Closes Norton Registry Tracker.
Closing Norton Registry Tracker prevents it from automatically tracking changes to 

your system.



Prevents this confirmation dialog box from appearing in the future. Check this box to exit 
Norton Registry Tracker without showing the Exit or Hide Norton Registry Tracker dialog box 
in the future.






